Gentoo Apache 2.4.3 升級後的怪問題.

如果出現
“Invalid command ‘User’, perhaps misspelled or defined by a module not included in the server configuration" ..
或是
“Invalid command ‘Require’, perhaps misspelled or defined by a module not included in the server configuration" ..

記得在 /etc/make.conf 內的 APACHE2_MODULES= 加上
[TEXT]
unixd access_compat authn_alias authn_core authz_core socache_shmcb
[/TEXT]
P.S 我一次全加了, 免得麻煩.
apache 網站的說明是說 Require 是用到 access_compat , 實際上還是要將 authz_core 和 authn_core 加入

如果網站有 access denied 的狀況, 要將設定稍改一下
[TEXT]
# Order allow,deny
# Allow from all
Require all granted
[/TEXT]
舊的 Order 和 Allow 改用 Require command .
大概是這樣.

Comments

comments

Related Posts

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>