[Gentoo] pygtk 的小 Bug.

升級 Python 時, ccsm 會找不到 pygtk 無法執行,
經過追查, 在 emerge pygtk 時會出現

* Cleaning orphaned Python bytecode from /usr/share/pygtk/2.0/codegen ..
* Cleaning orphaned Python bytecode from /usr/lib/python2.4/site-packages ..
* Cleaning orphaned Python bytecode from /usr/lib/python2.5/site-packages ..
* Cleaning orphaned Python bytecode from /usr/lib/python2.4/site-packages ..
* Cleaning orphaned Python bytecode from /usr/lib/python2.5/site-packages ..
* Unable to establish /usr/lib/python2.5/site-packages/pygtk.py symlink
* Unable to establish /usr/lib/python2.5/site-packages/pygtk.pth symlink
/>>> Auto-cleaning packages…

再重新安裝這二個套件

emerge -av pygobject pygtk


最後再跑一次 python-update

/usr/sbin/python-update

跑 python-update 如果有什麼錯誤訊息, 就升級那個套件就可以了.
會花一點時間.

Ref.
pygtk unable to establish symlinks – nicotine won’t start

[Tags] Gentoo, Pygtk, python, emerge [/tags]

Comments

comments

Related posts

Related Posts

  1. Using Unbranded Firefox Unbranded Firefox 2.0.0.14 on Linux Linux

    what’s the mean of -av,thank you

  2. Using Mozilla Firefox Mozilla Firefox 3.0 on Gentoo Linux Gentoo Linux

    –ask –verbose

  3. Recent Links Tagged With "pygtk" - JabberTags - pingback on 2009/01/27 at 4:20 下午
  4. Using Mozilla Firefox Mozilla Firefox 3.5.0.0 on Gentoo Linux Gentoo Linux

    Thx. I meet same error with my wicd.

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Trackbacks and Pingbacks: